Multiplayer Editing Demo

Forum for discussion about TSRE features.
User avatar
Louis
Posts: 53
Joined: 09 Jan 2022, 11:33
Location: Moscorw
Contact:
A bug appeared that a section of rails was missing. It was originally, this problem is fixed only for one user, the second has a section. I am attaching screenshots from two screens.

Player1 - https://prnt.sc/26cyo37
Player2 - https://prnt.sc/26cylb3

After Player2 switched, the vector glitched. - https://prnt.sc/26cyox8

After restarting the server, the vectors at part of the station got bugged - https://prnt.sc/26cypgu

User avatar
Louis
Posts: 53
Joined: 09 Jan 2022, 11:33
Location: Moscorw
Contact:
Desynced when changing the type of land. They made a hill and leveled it back, it leveled off for one user, and remained the same for the second.

Player 1 who was removed and lost https://cdn.discordapp.com/attachments/ ... nknown.png
Player 2, who had a desynchronization, is also the second Player 1, who is standing still, but in fact he is building paths who had a desync https://prnt.sc/26d70db

After 4 minutes, Player 2 synchronized and the mountain leveled out and Player 1 began to move and what he did was drawn

Also, if the characters ASCII in the login use in the login does not work

User avatar
Goku
Site Admin
Posts: 355
Joined: 15 Jan 2019, 18:10
Location: Poland
Contact:
Louis wrote:
13 Jan 2022, 13:29
Also, if the characters ASCII in the login use in the login does not work
Are your settings.txt and users.txt set to utf8? I did try russian names and it worked great.
You can't use space, = , : , @ .

User avatar
Goku
Site Admin
Posts: 355
Joined: 15 Jan 2019, 18:10
Location: Poland
Contact:
Louis wrote:
13 Jan 2022, 13:29
Desynced when changing the type of land. They made a hill and leveled it back, it leveled off for one user, and remained the same for the second.
Sending heightmap data changes takes very long. If two users edit the same tile terrain at the same time, it can cause problems.

User avatar
Louis
Posts: 53
Joined: 09 Jan 2022, 11:33
Location: Moscorw
Contact:
Goku wrote:
13 Jan 2022, 15:05
Louis wrote:
13 Jan 2022, 13:29
Also, if the characters ASCII in the login use in the login does not work
Are your settings.txt and users.txt set to utf8? I did try russian names and it worked great.
You can't use space, = , : , @ .

I understood about the tile, but about the fact that we have a problem with the paths that I wrote about above.

User avatar
Louis
Posts: 53
Joined: 09 Jan 2022, 11:33
Location: Moscorw
Contact:
Goku wrote:
13 Jan 2022, 15:05
Louis wrote:
13 Jan 2022, 13:29
Also, if the characters ASCII in the login use in the login does not work
Are your settings.txt and users.txt set to utf8? I did try russian names and it worked great.
You can't use space, = , : , @ .

I'll check, well, in general, UTF8

User avatar
Louis
Posts: 53
Joined: 09 Jan 2022, 11:33
Location: Moscorw
Contact:
Did you receive my message in the mail that I wrote to you about cooperation?

User avatar
Goku
Site Admin
Posts: 355
Joined: 15 Jan 2019, 18:10
Location: Poland
Contact:
Yes. I did send you short reply.

User avatar
Goku
Site Admin
Posts: 355
Joined: 15 Jan 2019, 18:10
Location: Poland
Contact:
Louis wrote:
13 Jan 2022, 15:50
I understood about the tile, but about the fact that we have a problem with the paths that I wrote about above.
Check last sentence of this post:
http://www.onrails.eu/viewtopic.php?p=1249#p1249
Maybe it is it? I don't know. It is a more difficult thing to solve.

User avatar
Goku
Site Admin
Posts: 355
Joined: 15 Jan 2019, 18:10
Location: Poland
Contact:
Louis wrote:
13 Jan 2022, 15:51
I'll check, well, in general, UTF8
Then, can you show me an example that doesn't work?

Post Reply